[ Foro de Pseudocódigo ]

ejercicio de repaso propuesto 6.1

02-Jan-2014 18:34
Carolina Sanchez
6 Respuestas

hola no se como hacer para generar dos numeros al azar entre 1 y 100 me podrian ayudar?


03-Jan-2014 01:35
Nacho Cabanes (+31)

Mira el apartado 10, sobre funciones matemáticas. La última función de la lista es la que necesitas. ;-)

http://www.aprendeaprogramar.com/mod/resource/view.php?id=421

(He detallado un poco más el enunciado del ejercicio 6.1, para que sea un poco más guiado, gracias por el aviso).


03-Jan-2014 17:55
Carolina Sanchez

Gracias por responder! ya pude solucionarlo..


21-Feb-2014 10:38
María del Carmen Rodríguez Fernández

Hola.
Yo también tengo dudas en este apartado:
-La suma de mis números aleatorios es siempre la misma. "0+0"
-No entiendo porque tengo que decir que "numero<-0" para que funcione. Supongo que es como en el ejemplo que propones "Mientras01", donde "suma<-0", que tampoco entiendo, porque x debería ser 0 para terminar.
Para que entiendas lo que te pregunto, ahí va lo que he escrito:


21-Feb-2014 10:41
María del Carmen Rodríguez Fernández

Hola soy yo de nuevo.
Perdón. Se me ha olvidado poner lo que yo he programado, por si tu ves el problema.

 
Proceso Ejercicio61
	Escribir "Calcula la suma ", numero, "+", numero;	
	Leer x;
	numero<-AZAR(101);
	numero<-0;
	Mientras x <> suma Hacer
		suma<-numero+numero;
		Escribir "La suma es incorrecta.";
		Escribir "Calcula otro valor";
		Leer x;
	Fin Mientras
	Escribir "La suma es correcta. Terminado";
FinProceso
 


Muchas gracias


21-Feb-2014 10:48
Nacho Cabanes (+31)

Observa estas dos líneas:

 
numero<-AZAR(101);
numero<-0;
 


Si primero le das el valor el azar, pero luego cambias su valor por cero, por supuesto que valdrá cero.  ;-)


21-Feb-2014 11:47
María del Carmen Rodríguez Fernández

Ok. Muchas gracias. Resuelto.
Por supuesto, no tenía ningún sentido darle a lo mismo dos valores distintos. Me he despistado con el ejemplo "Mientras01" por suma<-0. Pero ya lo he entendido.
Muchas gracias.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)