[ Foro de Pseudocódigo ]

ejercicio de repaso propuesto 9.1

04-Jan-2014 00:37
Carolina Sanchez
4 Respuestas

Hola me podrian ayudar no se como hacer el ejercicio con matrices!? gracias


04-Jan-2014 20:53
Nacho Cabanes (+32)

El enunciado es: Crea un programa que pida un número al usuario un número de mes (por ejemplo, el 4) y diga cuántos días tiene (por ejemplo, 30). Debes usar una matriz.

Por tanto, necesitarás un matriz con 12 elementos. Cada uno de esos elementos será el nombre de un mes. Cuando el usuario diga un número, extraerás el elemento que está en esa posición.

Pon aquí lo que hayas intentado, para que te podamos dirigir un poco más...


09-Feb-2014 20:16
Invitado (Nacho)

Hola,
Tengo problemas para hacer este ejercico. Mi código es el siguiente:

 
Proceso DiasMes
	i <- 0
	Dimension datos[12]
 
	datos[1]<-31;
	datos[2]<-28;
	datos[3]<-31;
	datos[4]<-30;
	datos[5]<-31;
	datos[6]<-30;
	datos[7]<-31;
	datos[8]<-31;
	datos[9]<-30;
	datos[10]<-31;
	datos[11]<-30;
	datos[12]<-31;
 
	Escribir "Dime un número de mes";
	Leer datos[i];
	Escribir "El mes tiene " ,i " días";
FinProceso
 


El problema es que no sé como leer el número introducido por el usuario y apuntar a la matriz para usar el dato.

Un saludo.


09-Feb-2014 23:56
Luis Torres (+12)

En un arreglo debes distinguir entre el índice del arreglo y el valor asignado a la variable relacionada con ese índice. Para el caso de este problema, el índice representa al número del mes del año, si vale uno será enero, dos para febrero y así sucesivamente. O sea que, en el pseudocódigo, cuando pides el número del mes, debes leerlo en el índice, el cual es "i"; luego, la cantidad de días de la variable del arreglo relacionada con "i" será datos[i]. Por lo tanto, esa parte del pseudocódigo deberá quedar así:

 
Escribir "Dime un número de mes";
Leer i;
Escribir "El mes tiene ",datos[i]," días";
FinProceso
 



10-Feb-2014 19:41
Invitado (Nacho)

Ok, ahora lo entiendo.
Muchísimas gracias.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)