[ Foro de Pseudocódigo ]

práctica 6,1. AYUDA

20-Jun-2014 23:19
Invitado (Zz)
3 Respuestas

Al ejecutar el programa me sale calcula la suma y no me sale los números al azar por lo que no tengo ningún número para poder sumar.... Si alguien me pudiera decir que tengo mal... os dejo  lo que he escrito:

 
Proceso práctica
	Escribir "Calcula la suma", número, "+", número;
	leer x;
	numero<-AZAR(101);
	mientras x<> suma hacer
		suma<-numero+numero;
		Escribir "La suma es incorrecta, repita la operación";
		Leer x;
 
	FinMientras
	Escribir "La suma es correcta, fin";
 
FinProceso
 



21-Jun-2014 00:32
Luis Torres (+12)

Deberías explicar en palabras lo que pretendes que tu programa haga.
Noto varios errores de diseño del programa. En la línea:

 
   Escribir "Calcula la suma", numero,"+", número;
 


estás pidiendo mostrar el valor de la variable número antes de que esta sea asignada al azar. Lo lógico es que primero se le asigne un valor y luego lo escribas en pantalla.
Otro error que veo, es que en el ciclo "mientras":

 
   mientras x<>suma hacer
 


¿cómo puedes comparar la variable x con la variable suma, si suma aún no guarda ningún valor? Lo correcto sería asignarle un valor a suma antes de que pase a formar parte de la condición de un ciclo "mientras".
Saludos.


21-Jun-2014 14:17
Invitado (zz)

Muchas gracias, ya he corregido el error!
Os dejo el código por si alguien más tiene alguna duda

 
Proceso práctica
	 número<-AZAR(101)
	Escribir "Calcula la suma", número, "+", número;
	leer suma
	mientras x<> suma hacer
		x<-número+número;
		Escribir "La suma es incorrecta, repita la operación";
		Leer suma
 
 
	FinMientras
	Escribir "La suma es correcta, fin";
 
FinProceso
 



22-Jun-2014 15:10
Nacho Cabanes (+30)

Sigue con errores, pero como has abierto un nuevo hilo (¿por qué?), te contesto en él...






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)