[ Foro de Pseudocódigo ]

Ayuda con ejercicio 10.1

22-Jun-2014 16:18
Invitado (zz)
3 Respuestas

Soy nueva en esto... y no tengo mucha idea. La práctica dice lo siguiente:Ejercicio de repaso propuesto 10.1: Crea un programa que genere un número al azar entre el 1 y el 100. El usuario tendrá 7 oportunidades para adivinarlo. Tras cada intento, se le dirá si se ha pasado o se ha quedado corto.
No me aclaro mucho, a ver si me podéis dar una pista a cómo hacerlo, llevo esto:

 
Proceso práctica
	número<-AZAR(101)
	Repetir
		Escribir "Dime el número"
		leer x
		si x<> número Entonces
			Escribir "Clave incorrecta"
		FinSi
	Hasta Que x=número
 
FinProceso
 


No es mucho pero estoy empezando, disculpen las molestias.


22-Jun-2014 16:39
Nacho Cabanes (+30)

Te falta comprobar si se pasa o se queda corto (en vez de simplemente si es distinto), y llevar un contador para asegurarte de que no gaste más de 6 intentos.

Y, como te he dicho en hilos anteriores, los nombres "práctica" y "número", con acentos, no serán aceptables en la mayoría de entornos de programación reales.


22-Jun-2014 19:36
Invitado (zz)

Muchas gracias, vale ya he corregido lo de los acentos y he puesto si se pasa o no, lo que no sé hacer ahora es que solo hayan siete intentos... Cómo lo hago?

 
Proceso practica
	numero<-AZAR(101)
	Repetir
		Escribir "Dime el numero"
		leer x
		si x> numero Entonces
			Escribir "Clave incorrecta, el número es menor"
		FinSi
		si x<numero entonces
			escribir "Clave incorrecta, el número es mayor"
		FinSi
	Hasta Que x=numero
	Escribir "Correcto"
 
FinProceso
 



26-Jun-2014 09:15
Nacho Cabanes (+30)

Necesitas un contador, que comenzará en 1 (o en 0, según como lo quieras plantear) y que se incrementará en 1 en cada pasada.

Ahora tendrás dos condiciones de salida: mientras no se acierte y no se agoten los intentos.

Y cuando finalmente se salga, como puede haber sido por dos motivos distintos, debes comprobar si ha acertado el número ("ha ganado") o no (ha agotado intentos, "ha perdido").






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)