[ Foro de C# ]

INSTALADOR C#

02-Oct-2014 04:28
Invitado (ANA LUCIA)
3 Respuestas

TENGO EL SIGUIENTE PROBLEMA CON UN SISTEMA REALIZADO EN C# ,  ES QUE TENGO  UN SISTEMA QUE LO INSTALO EN LOS EQUIPOS DE  DONDE SE REQUIERE , LA CUESTION ES QUE CUANDO INGRESO AL SISTEMA Y  CAMBIO DE UNA PANTALLA A OTRA TARDA MUCHO TIEMPO.
NO SE PORQUE .

MI SISTEMA ESTA CONECTADO  UN SERVIDOR Y LA BD ES SQL SERVER  CON UNA CONEXION PUBLICA PARA PODER ACCESAR   DE AFUERA


03-Oct-2014 22:40
Nacho Cabanes (+32)

Es un problema demasiado poco concreto, faltan muchos detalles para poder saber realmente qué ocurre.

Aun así, por si te da sirve de pista de uno de los posibles problemas, a mí en alguna ocasión me han pasado cosas parecidas usando PHP+MySQL en equipos Windows, y generalmente se debía a usar IP4 en equipos que tienen la red configurada para IPV6, de modo que cada petición de red se debe convertir de un formato de IPs a otro y resolver posteriormente.


04-Oct-2014 05:02
ANA LUCIA bernal

el acceso a la base de datos esta en buen tiempo , las consultas , los procesos con los datos , el unico incoveniente es que si el usuario quiere cambiar de un formulario a otro tarda aprox 8 segundo para dar respuesta , en uno de los foros me dicen que cambie las propiedades que el lenguaje me da por defaul  por ejemplo el tipo de letras.

crees que sea eso ?


05-Oct-2014 02:06
Nacho Cabanes (+32)

El tipo de letra no debería afectar, a no ser que el equipo de destino tenga muchísimos tipos de letra instalado y sea muy lento.

Mira qué procesos se producen al abrir el nuevo formulario (¿conectar a una base de datos y pedir información?  Â¿esa base de datos es remota?  Â¿abrir ficheros de configuración? ¿pedir datos a otras clases que hagan alguna de esas operaciones?...) Quizá incluso un antivirus que no exista en tu equipo de desarrollo pueda estar monitorizando y ralentizando esos pasos.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)