[ Foro de BASIC ]

ejercicio 10.1- El enunciado dice: Crea un programa que genere un número al azar entre el 1 y el 100. El usuario tendrá 7 oportunidades para adivinarlo.

08-Nov-2014 00:11
Invitado (Sebastian)
1 Respuestas

Ya logre las 7 oportunidades con una matriz y se describe si estoy por encima  o por debajo del nu

 
Proceso ejercicios1001
	Dimension datos[7]
	Escribir "Adivina el numero tienes 7 intentos"
	Escribir " Recuerda el numero esta entre 0 y 100"
	x<-AZAR[100]
	Para r<-1 Hasta 7  Hacer
		Leer datos[r]
		si datos[r]>x Entonces
			Escribir "Clave incorrecta, el número es menor"
		FinSi
		si datos[r]<x entonces
			escribir "Clave incorrecta, el número es mayor"
		FinSi
		si datos[r]=x
			Escribir " felicitaciones ese numero no hacen falta mas intentos" 
		FinSi
	fin para
FinProceso
 




09-Nov-2014 01:49
Nacho Cabanes (+32)

Por una parte, no necesitas matrices. Por otra parte, esta pregunta parece de pseudocódigo, no de BASIC. Finalmente, has puesto toda la pregunta en el titulo, así que ha aparecido truncada. Detalla qué problema tienes.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)