[ Foro de Pseudocódigo ]

Ejercicio propuesto 8

20-Nov-2014 23:50
Invitado (Andres)
3 Respuestas

El enunciado dice asi : Crear un algoritmo que pida al usuario que introduzca una frase, y diga cuántas veces contiene la letra A (ya sea en mayúsculas o en minúsculas).
No entiendo ni como comenzar


21-Nov-2014 09:44
Nacho Cabanes (+31)

Doy por sentado que sabes pedir una frase. A partir de ahí, deberías recorrerla con "para", extrayendo letra a letra, y comparando si es letra es una "A" o es una "a".

Pon aquí tu intento, para ver si lo estás orientando bien.


24-Nov-2014 03:12
Invitado (Andres)

Gracias, Ya logre hacerlo solo me faltaba comprender un poco mas lo de la subcadena ademas de que no comprendía porque se colocaba dos veces x (en mi caso) pero entendí que era para marcar un inicio y fin.

Proceso texto1
Escribir "Dime una frase"
Leer frase
Para x<-1 Hasta longitud(frase) Hacer
r<-Subcadena(frase,x,x)
si r="a"
p<-p+1
FinSi
Fin Para
Escribir " la letra a aparece ",p,"Vecez"
FinProceso


25-Nov-2014 10:16
Nacho Cabanes (+31)

Exactamente. Bien hecho!






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)