[ Foro de Pseudocódigo ]

Alternando mayusculas y minúsculas

29-Nov-2014 02:53
Invitado (Sebastian)
5 Respuestas

El enunciado dice esto: Crea un programa que pida su nombre al usuario y lo escriba alternando letras mayúsculas y minúsculas (por ejemplo, "Nacho" se mostraría como "NaChO"
Ya cree la subcadena  pero no se como hacer que cuando llegue a un numero determinado de esta , cambie a mayuscula .
se q esto podria ser el principio

 
Proceso alternandoletras
	Escribir "Dime una palabra"
	Leer r1
	Para j<-1 Hasta longitud(r1) Hacer
		p<-subcadena( r1,j,j)
		Fin Para
	FinProceso 
 




29-Nov-2014 12:50
Nacho Cabanes (+30)

Ese ejercicio está en el apartado 13 del curso:

http://www.aprendeaprogramar.com/mod/resource/view.php?id=485

Verás que ahí tienes explicado que puedes usar "mayusculas(x)" para convertir a mayúsculas una variable que contenga un texto, y de forma parecida lo puedes convertir a minúsculas.

Sólo te falta afinar la idea de "si j es impar, escribir mayusculas(p) ..."


02-Dec-2014 03:09
Invitado (Sebastian)

No lo logro no se que tengo mal o depronto estoy definiendo mal la parte del par o tomando la variable incorrecta,disculpen la molestia

 
Proceso alternandoletras
	Escribir "Dime una palabra"
	Leer r1
	Para j<-1 Hasta longitud(r1) Hacer
		p<-subcadena(r1,j,j)
	Fin Para
	Si j Es Par   Entonces
		Escribir Mayusculas(p)
	finsi
FinProceso
 




02-Dec-2014 09:59
Nacho Cabanes (+30)

Vale, ya veo el problema. Eso de "si j es par" es lenguaje natural, pero no se puede escribir tal cual en la mayoría de notaciones de pseudocódigo. Generalmente hay que comprobar el resto de dividir j entre 2.

He ampliado ligeramente el apartado 2 para indicar cómo se puede hacer esa operación con PseInt (y he añadido otros 3 ejercicios propuestos):

http://www.aprendeaprogramar.com/mod/resource/view.php?id=357

además, en tu fuente hay dos pequeños detalles que corregir:

- Por una parte, el "si" que comprueba si una posición es par o no, debería estar dentro del "para" que revisa las letras.

- Por otra parte, te falta el "si no" de ese último "si" ("sino" en Pseint), que muestre en minúsculas cuando no es par.


08-Dec-2014 23:20
Invitado (Sebastian)

ok listo ya pude

 
Proceso alternandoletras
	Escribir "Dime una palabra"
	Leer r1
	Para j<-1 Hasta longitud(r1) Hacer
		p<-subcadena(r1,j,j)
		Si j%2=1  Entonces
			Escribir Mayusculas(p)
		Sino
			Escribir Minusculas(p)
		finsi
	Fin Para
	FinProceso
 


gracias


09-Dec-2014 01:51
Nacho Cabanes (+30)

¡Exacto!  Esa es la forma.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)