[ Foro de Pseudocódigo ]

Texto centrado en pantalla

10-Dec-2014 01:15
Invitado (Sebastian)
2 Respuestas

El enunciado dice asi : Crea un subproceso que reciba como parámetro un texto y lo escriba centrado en pantalla (suponiendo una anchura de 80 columnas)
No se que es lo que tengo mal o no he entendido bien el ejercicio ,esto es lo que he logrado, seria de gran ayuda  una respuesta

 
Proceso centrodepantalla
	lafrase(80,"Texto centrado")
FinProceso
subproceso lafrase (p,texto)
	Para r<-1 Hasta p  Hacer
		Escribir " "
	Fin Para
	Para x<-1 Hasta p  Hacer
		Escribir Sin Saltar " "
	finpara
	escribir texto
	Para s<-1 Hasta p  Hacer
		Escribir " "
	FinPara
FinSubProceso
 




11-Dec-2014 09:47
Nacho Cabanes (+31)

Estás escribiendo 80 (p) espacios, y no se trata de eso.

La idea es que si tienes 80 columnas y quieres escribir centrado un texto de 20 letras, el espacio inicial que deberás dejar (usando "escribir sin saltar") será de (80-20) / 2 = 30 espacios


13-Dec-2014 00:48
Invitado (Sebastian)

ok , gracias






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)