[ Foro de Pseudocódigo ]

Ejercicio 12.3 (Mayor de 3)

27-May-2015 17:44
Invitado (Ruben)
1 Respuestas

Buenas, habria alguna otra manera de resolver el problema a parte de esta?:

 
Proceso mayorde3
	Dimension datos(3)
 
	Para i <- 1 Hasta 3 Hacer
		Escribir "Dime 1 cifra"
		Leer datos(i)
	FinPara
 
	Si datos(1) > datos(2) & datos(1) > datos(3) Entonces
		Escribir "El mayor es ", datos(1)
	FinSi
 
	Si datos(2) > datos(1) & datos(2) > datos(3) Entonces
		Escribir "El mayor es ", datos(2)
	FinSi
 
	Si datos(3) > datos(1) & datos(3) > datos(2) Entonces
		Escribir "El mayor es ", datos(3)
	FinSi
 
FinProceso


 


27-May-2015 18:25
Nacho Cabanes (+32)

Esa se parece mucho a la buena. Prueba a introducir los datos 5, 5, 5 y verás que todavía no es perfecta.

Una vez corregido ese detalle, no es necesario usar un array, basta con 3 variables independientes, y podrás eliminar la última condición si usas "si no" (siempre y cuando las condiciones ya sean las correctas, claro).






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)