[ Foro de Pseudocódigo ]

Ayuda con ejercicio 10.1

08-Jun-2015 21:38
Invitado (Sara)
2 Respuestas

Hola, el ejercicio consta de elaborar un programa que genere un número al azar entre el 1 y el 100. El usuario tendrá 7 oportunidades para adivinarlo. Tras cada intento, se le dirá si se ha pasado o se ha quedado corto.
Lo trabajé de la siguiente manera y ha funcionado excepto porque una vez que adivinas continua ejecutando las oportunidades restantes. ¿Cómo puedo detener la ejecución una vez que adivinan el número?

 
Proceso repasodiezuno
	Definir x como entero;
	Definir i como entero;
	Definir datos como entero;
 
	x<- AZAR(101);
	Dimension datos[7];
 
	Para i<-0 Hasta 6  Hacer
		Escribir "Adivina el número ", i " oportunidad";
		Leer datos[i];
		Si datos[i] < x Entonces
			Escribir " Fallaste! Tu numero es menor";
		Sino
			Si datos[i]>x Entonces
				Escribir "Fallaste! Tu numero es mayor";
			Sino
				Si datos[i]=x Entonces
					Escribir "Felicidades! Acertaste!";
				FinSi
			FinSi
		Fin Si
 
	Fin Para
	Si datos[6]<>x Entonces;
		Escribir "Se te acabaron las oportunidades! :(";
 
	Fin Si
FinProceso
 


 


11-Jun-2015 10:45
Nacho Cabanes (+32)

Deberás cambiar ese "PARA" por un "MIENTRAS" que compruebe dos condiciones: el contador y si se ha acertado.


13-Jun-2015 02:31
Invitado (Sara)

Gracias! Ya lo logré!!!






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)