[ Foro de Pseudocódigo ]

Ejercicio 12.4 duda

18-Jun-2015 19:07
Invitado (Sara)
2 Respuestas

He desarrollado el ejercicio de la siguiente manera y me marca error al probarlo. Indica que es un error de subíndice fuera de rango. He intentado cambiar el subíndice por 4 contemplando el cero pero aún así me sigue marcando el mismo error.

 
Proceso cuatrodoce
	Definir datos como Entero;
	Definir i Como Entero;
	Definir z como Entero;
 
 
	Dimension datos[5];
	Para i <-1 Hasta 5 Hacer
		Escribir "Dame un dato",i;
		Leer datos[i];
	Fin Para
 
	Escribir "Dame un numero con el cual comparar los anteriores";
	Leer z;
 
	Para datos[i]<-1 Hasta 5 Hacer
		Si datos[i]>z Entonces
			Escribir datos[i], "es mayor que  ", z;
		Fin Si
	Fin Para
 
 
FinProceso
 


 


21-Jun-2015 00:32
Nacho Cabanes (+32)

En el segundo "para" estás usando "datos[i]" en vez de "i". Si quieres recorrer todos los valores, debería comenzar igual que el primer "para":

 
Para i <-1 Hasta 5 Hacer
 




28-Jun-2015 19:47
Invitado (Sara)

Gracias ya lo logré!






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)