[ Foro de Pseudocódigo ]

Realizar contador de intentos Ejercicio Propuesto 10.1

02-Oct-2015 18:19
Euler Vasquez
1 Respuestas

Muy buenos dias, necesito ayuda con este ejercicio propuesto 10.1, dado que el mismo lleva un limite de intentos y no se como realizar esto, e realizado un codigo que cumple con las demas condiciones pero aun me falta esta que es una de las primordiales. A continuacion les coloco el Mandato del ejercicio y el Codigo generado.

MANDATO:
Crea un programa que genere un numero al azar entre el 1 al 100. El usuario tendra 7 oportunidades para adivinarlo. Tras cada intento, se le dira si se ha pasado o se ha quedado corto.

CODIGO GENERADO:

 
Proceso Ejercicio10
	Definir Num_sum Como Entero
	Definir Num_cr	Como Entero
 
	Num_cr <- Azar(101)
	Repetir
		Escribir "Adivinar numero generado al azar ", Num_cr;
		Leer Num_sum;
	Si Num_sum < Num_cr Entonces
		Escribir "Numero suministrado es menor que el valor deseado";
	FinSi
	Si Num_sum > Num_cr Entonces
		Escribir "Numero suministrado es mayor que el valor deseado";
	 FinSi
 
Hasta Que Num_sum = Num_cr
Escribir "Acertaste! Numero indicado correctamente"
 
FinProceso
 


 


09-Oct-2015 11:43
Nacho Cabanes (+30)

Tu solución se acerca mucho a la correcta. Te falta poco más que añadir una segunda condición a la cláusula "hasta", porque se debe abandonar también si el número de intentos ya ha alcanzado 7.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)