[ Foro de BASIC ]

Ejercicio de repaso propuesto 10.1

16-Oct-2015 00:05
Invitado (Lockedr)
1 Respuestas

Buenas tardes,
Me gustaría que me ayudaran a identificar el problema que tengo, ya que el programa funciona pero no se detiene en la oportunidad numero 7 o cuando acierta el numero pedido, anexo mi ejercicio.

 
Proceso sin_titulo
	x<-azar(101)
	i<-0
	dimension datos[7];
	Mientras i<>x Hacer
		Para e<-1 Hasta 7 
			escribir " digite el  numero de 1 a 100"
			leer i;
			Si datos[i]>x Entonces
				escribir "EL NUMERO ES MENOR"
			Sino
				Si datos[i]<x Entonces
					escribir "EL NUMERO ES MAYOR"
				Sino
					Si datos[i]=x Entonces
						escribir "Felicidades Acertatre !!!!"
					FinSi
				FinSi
			FinSi
		FinPara
	FinMientras
FinProceso
 



no se como copiar en texto normal

gracias de antemano




25-Oct-2015 02:40
Nacho Cabanes (+32)

Te basta con añadir dos condiciones al "mientras", en vez de hacer que el "mientras" contenga un "para". Una de las condiciones será la de que no se haya encontrado, como ya lo tienes, y la otra será que no se haya agotado todos los intentos.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)