[ Foro de Pseudocódigo ]

Ejercicio propuesto 9.4

04-May-2016 18:44
Raquel Miranda
1 Respuestas

Es el siguiente:
crea un programa que reserve espacio para dos vectores de 3 componentes, pida al usuario sus valores y calcule la suma de ambos vectores (su primera componente será x1+y1, la segunda será x2+y2 y así sucesivamente.

Mi duda es si la siguiente estructura es la adecuada(si comprendí el ejercicio y si lo hice bien):

 
Proceso sin_titulo
	acum<-0; acum2<-0
 
	Dimension vector1[3]
	Para i<-1 Hasta 3 Con Paso 1 Hacer
		Escribir "Digite un numero", i;
		Leer num;
 
		vector1[i]<-num
		acum<-acum + vector1[i]		
	FinPara
 
	Dimension vector2[3]
	Para i<-1 Hasta 3 Con Paso 1 Hacer
		Escribir "Digite un numero", i;
		leer num;
 
		vector2[i]<-num
		acum2<-acum2+vector2[i]		
	FinPara
 
	Dimension vector3[2]
	vector3[1]<-acum+acum2
 
	Escribir "Resultado total <- ", vector3[1];
FinProceso
 


Muchas gracias :)


08-May-2016 16:50
Nacho Cabanes (+30)

Se acerca. La petición de datos está bien, pero el resultado debería ser un nuevo vector de 3 elementos, no de 2 elementos, y cada una de sus componentes debería ser la suma de un elemento del primero vector y otro del segundo vector.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)