[ Foro de Pseudocódigo ]

NECESITO EL CODIGO

05-Jul-2016 09:11
Invitado (CODIGO CESAR PSEINT)
1 Respuestas

Estimados,

Necesito su ayuda para crear un codigo en PSEINT el cual sea capas de decifrar el codigo Cesar, ya tengo el codigo para encriptar, pero necesito uno para poder desencriptar el mismo...


Funcion cifrado <- cesar(f,c)
definir abc,cifrado,decifrado Como Caracter;
Definir i,j,k Como Entero;
Dimension abc[26];
cifrado <- "";


abc[0]<- "a";
abc[1]<- "b";
abc[2]<- "c";
abc[3]<- "d";
abc[4]<- "e";
abc[5]<- "f";
abc[6]<- "g";
abc[7]<- "h";
abc[8]<- "i";
abc[9]<- "j";
abc[10]<-"k";
abc[11]<-"l";
abc[12]<-"m";
abc[13]<-"n";
abc[14]<-"o";
abc[15]<-"p";
abc[16]<-"q";
abc[17]<-"r";
abc[18]<-"s";
abc[19]<-"t";
abc[20]<-"u";
abc[21]<-"v";
abc[22]<-"w";
abc[23]<-"x";
abc[24]<-"y";
abc[25]<-"z";

Para i <- 0 Hasta (Longitud(f)-1) Con Paso 1 Hacer
Si (Subcadena(f,i,i) = " ") Entonces
cifrado <- Concatenar(cifrado," ");
Sino
Para j<-0 Hasta 25 Con paso 1 Hacer
Si (Subcadena(f,i,i) = abc[j]) Entonces
Si ((j+c)>25) Entonces
k<-((j+c)-26);
Sino
k<-j+c;
FinSi
cifrado <- Concatenar(cifrado,abc[k]);
FinSi
FinPara
FinSi
FinPara

FinFuncion



Proceso cifrar
Definir frase Como Caracter;
Definir x Como Entero;

Escribir "Ingrese Frase a cifrar";
Leer frase;
Escribir "Ingrese desplazamiento del cifrado";
Leer x;
Limpiar Pantalla;
frase <-minusculas(frase);


Si (x > 26) Entonces
Escribir "El corrimiento no puede ser mayor a 26";
Sino
Escribir "La frase: ´´",frase, "´´ es: ",cesar(frase,x);
FinSi;
FinProceso


12-Jul-2016 13:58
Nacho Cabanes (+31)

¡Pero si casi lo tienes! Si entiendes la idea del cifrado (todas las letras se desplazan hacia la derecha una cierta cantidad de posiciones), verás que el descifrado es idéntico al cifrado, excepto por el detalle de que se resta un cierto valor (la clave de cifrado) en vez de sumarlo, para desplazar hacia la izquierda.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)