[ Foro de Pseudocódigo ]

Ejercicio 6.3

12-Jul-2016 17:47
Lucia Caro
1 Respuestas

Crea un programa que genere dos números al azar entre el 0 y el 100, y pida al usuario que calcule e introduzca su suma. Si la respuesta no es correcta, deberá volver a pedirla tantas veces como sea necesario hasta que el usuario acierte.
Pista: como verás en el apartado 10, para generar un número al azar del 0 al 100 puedes hacer numero <- AZAR(101)

No entiendo muy bien el enunciado y ademas, ¿como hago para que el programa me genere dos numeros entre 0 y 100?


13-Jul-2016 13:14
Invitado (holacaracola)

Te pide que generes dos números que estén entre el 0 y el 100. Esto se hace así:

 
x <- AZAR(101)
	Escribir " ", x
z <- AZAR (101)
	Escribir " ", z
 


Entonces a partir de estos números, el usuario debe introducir el resultado de la suma entre estos, si es incorrecta entonces el programa le pide que lo vuelva a intentar hasta que el resultado de la suma sea el correcto.

Espero haberte ayudado!

Te dejo aquí lo que yo he hecho:

 
Algoritmo Ejercicio63
	x <- AZAR(101)
	Escribir " ", x
	z <- AZAR (101)
	Escribir " ", z
	n <- x + z
 
	Escribir "Calcular suma"
	Leer n
 
	Mientras NO x + z  = n  Hacer
		suma <- x + z = n
		Escribir "Incorrecto";
		Escribir "Vuelva a calcular"
		Leer n
	FinMientras
	Escribir "Bien";
FinAlgoritmo
 


 






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)