[ Foro de Java ]

Algoritmo con frase

23-Sep-2016 03:13
Invitado (anonimo)
1 Respuestas

escribir una frase y mostrar
1.cuantos espacios en blanco hay
2.cuantas vocales hay sin repetir las vocales.
3.mostrar la letra de la mitad.

En pseint por favor


27-Sep-2016 06:20
jose mogollon

hola, esta puede ser una manera, trate de hacerlo lo mas detallado que puede, entiende bien el codigo y la logica, para que asi puedes quitar la redundancia y poder hacer otra logica, espero te ayude, saludos,

 
Proceso frase
	Definir ingreso como cadena;
	definir total como real;
	Definir conteoEspacio, a, e, ii, ou, u, totalVocales como entero;
	a <- 0; e <- 0; ii <- 0; ou <- 0; u <- 0; conteoEspacio <- 0; totalVocales <- 0; total <- 0;
	Definir letra como caracter;
	escribir "Ingrese frase: ";
	leer ingreso;
	total <- longitud(ingreso);
	dimension arreglo[total];
	para i <- 1 hasta total
		arreglo[i] <- subcadena(ingreso,i,i);
	FinPara
	para i <- 1 hasta total
		si arreglo[i] == " " Entonces
			conteoEspacio <- conteoEspacio + 1;
		FinSi
 
		si arreglo[i] == "a" o arreglo[i] == "A" Entonces
			si a == 0 Entonces
				a <- a + 1;
			FinSi		
		finsi
		si arreglo[i] == "e" o arreglo[i] == "E" Entonces
			si e == 0 Entonces
				e <- e + 1;
			FinSi
		FinSi
		si arreglo[i] == "i" o arreglo[i] == "I" Entonces
			si ii == 0 Entonces
				ii <- ii + 1;
			FinSi
		FinSi
		si arreglo[i] == "o" o arreglo[i] == "O" Entonces
			si ou == 0 Entonces
				ou <- ou + 1;
			FinSi
		FinSi
		si arreglo[i] == "u" o arreglo[i] == "U" Entonces
			si u == 0 Entonces
				u <- u + 1;
			FinSi
		FinSi
	FinPara
 
	totalVocales <- a + e + ii + ou + u;
	total <- total / 2;
 
	Escribir "Total Espacios: ", conteoEspacio;
	Escribir "Total Vocales: ", totalVocales;
	Escribir "Letra en la Mitad: ", arreglo[trunc(total)];
 
FinProceso
 


---------------------------------------------------------------------------
en un lenguaje de progrmacion como por ejemplo java seria mucho mas sencillo.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)