[ Foro de Pseudocódigo ]

POR FAVOR

25-Oct-2017 18:01
Invitado (AYUDA CON EXAMEN )
1 Respuestas

1. Escriba un algoritmo que defina un arreglo de enteros de largo 10.
a. Considere al llenarlo:
i. Sólo recibe números pares
ii. No recibe números múltiplos de 48
iii. Todos los números menores de 20 deben ubicarse en las celdas impares del arreglo. Otros números en las celdas restantes
b. Considere al mostrar los datos
i. Mostrar el arreglo completo en una fila
ii. Valores separados por coma (,)
iii. Mostrar cuántos números múltiplos de 4 se ingresaron
iv. Mostrar sólo los valores pares menores de 20
v. Mostrar el promedio de los valores de las celdas impares
c. Cree un menú para las opciones de salida.
d. Este algoritmo debe repetirse hasta que el usuario decida que ya no más


E REALIZADO UN CODIGO UTILIZANDO DOS CONTADORES PERO AUN ASI NO LOGRO TERMINARLO

 
Proceso sin_titulo
Definir arr Como Entero;
Dimension arr[10] ; 
Definir cont como entero;
cont<-0;
Repetir	
Escribir "ingrese un valor";
repetir 
leer arr[cont];
hasta que arr[cont] mod 2=0 y arr[cont] mod 48>0 y arr[cont]!=0
 
si arr[cont] < 20 entonces
cont1<-0;
arr[cont1]<-arr[cont];
cont1<-cont1+2;
sino 
cont2<-1;
arr[cont2]<-arr[cont];
cont2<-cont2+2;
FinSi
 
 
cont<-cont+1;
Hasta Que cont=9
FinProceso
 


 


27-Oct-2017 11:11
Nacho Cabanes (+32)

A la hora de llenarlo, yo usaría dos órdenes "para", con paso 2, de modo que primero recorriera los elementos impares, para colocar en ellos los números menores de 20. En una segunda pasada llenaría las posiciones pares con los siguientes números. Me parece más sencillo que intentar llenar todo a la vez. Si no conoces la orden "para", la tienes aquí:

http://www.aprendeaprogramar.com/mod/resource/view.php?id=412
 






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...