[ Foro de Pseudocódigo ]

Temas 9 y 10 + ejercicios

30-Nov-2009 23:18
Nacho Cabanes (+32)
7 Respuestas

He añadido dos temas breves: uno sobre matrices y otro sobre funciones matemáticas.

De igual modo, también hay una primera entrega del tema 11, que contendrá ejercicios resueltos (y que de momento sólo están propuestos ;-) )


05-Dec-2009 00:31
Carlos Botto

Espero con ansias la solucion al ejercicio 5, el del cuadrado ya no logro terminarlo. Los otros tres ya los resolvi!, felicitaciones por el curso


05-Dec-2009 23:42
Nacho Cabanes (+32)

Tienes publicada la solución del ejercicio 2. Para la del 5... tendrás que esperar unos días...  ;-)


06-Dec-2009 00:13
Carlos Botto

ok, espero, total mientras me entretengo con el curso de C que tenes en tu otra pagina.
Y el ejercicio 2 yo lo resolvi asi:

 
Proceso ComprobacionDeNumeros
	Escribir "Digame un numero: "
	Leer numero
 
    Segun numero Hacer
		0:
			Escribir "Su numero es 0"
		De Otro Modo:
			Si numero < 0 Entonces
				Escribir "Su numero es negativo"
			Sino
				Escribir "Su numero es positivo"
			FinSi
	FinSegun
FinProceso
 


Supongo q esta bien ya que el programa funciona xD


08-Dec-2009 21:40
Nacho Cabanes (+32)

Ya tienes todas las soluciones publicadas (aunque el 5 no se puede hacer con la versión actual de PseInt, pero doy las pautas de cómo se podría hacer).

Lo de usar "Según" para el ejercicio 2 es un poco como "matar moscas a cañonazos" ;-)  . Los puristas recomiendan usar "Si" para comprobar de 1 a 3 condiciones, y "Según" cuando son a partir de 4-5. No sólo es por legibilidad. También el programa resultante suele ser algo más rápido con "si" que con "según", sobre todo si planteas en primer lugar los casos más frecuentes.

Aun así, como ya has podido comprobar, funciona correctamente, así que es una solución válida, aunque pudiera llegar a mejorarse.

(Suerte con el C!)


09-Dec-2009 22:15
juan carlos costa rodriguez

tengo una duda referenta al ejercicio 3 que a lo mejor es una tonteria pero bueno, tambien es que llevo con este curso dos dias con .

por que siempre en la suma se pone <- y no se puede poner ->
gracias de antemano


14-Dec-2009 01:38
Nacho Cabanes (+32)

Lo de poner "<-" y no "->" en la suma es una cuestión de sintaxis. Igual que el símbolo de sumar es "+" y no cualquier otro, el símbolo que se usa para representar que se está almacenando un valor en una variable es "<-".

En la mayoría de lenguajes de programación, en vez de ese símbolo se emplea el de igualdad, así:

x = 2

pero eso puede confundirse con una igualdad matemática, y no es así: no se trata de que x siempre vaya a ser 2, sino de que en este momento le estamos dando el valor 2. Por eso, en pseudocódigo se suele preferir el símbolo de la flecha, para indicar que el valor 2 se introduce en el espacio de memoria que representa la variable x:

x <- 2

Lo mismo ocurre si el valor que guardamos en la variable x no es un número prefijado, sino el resultado de una suma o de otra operación matemática:

x <- 3 + 5
z <- 4 * x
resultado <- x / 10


15-Dec-2009 01:02
juan carlos costa rodriguez

gracias por despejar la duda






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)