[ Foro de Pseudocódigo ]

funcion Iniciales

15-Jan-2018 10:49
Invitado (SAra)
1 Respuestas

El enunciado en cuestion es: Crea una función Iniciales que devuelva una cadena formada por las iniciales de la frase que se indique como parametro.
Yo he llegado hasta aqui, pero solo consigo que me de la primera letra de la frase.

 
Funcion Iniciales(frase)
	Para x<-1 Hasta Longitud(frase) Hacer
		Escribir Sin Saltar Subcadena(frase,x,1)
	FinPara
	Escribir " "
 
FinFuncion
Proceso inicial
	Escribir " Introduce una frase"
	Leer frase
	Iniciales(frase)
 
FinProceso
 


Gracias


24-Jan-2018 23:39
Nacho Cabanes (+36)

Tienes que tener en cuenta dos detalles:

1. Podemos suponer que la primera letra es la primera inicial (si no han "ido a reventarte el programa" y han tecleado un espacio en primer lugar).

2. Para el resto de iniciales, deberás buscar a partir de la posición 2 (no la una), para escribir las letras que tengan un espacio antes (en la posición x-1).






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)