[ Foro de Pseudocódigo ]

Ayuda con triangulo 8.8

07-Jun-2018 14:01
Invitado (anna)
1 Respuestas

Hola, he intentado por varios caminos partiendo del rectángulo y no doy con el paso.
Tampoco veo en el foro referencia a este.
Gracias.

Algoritmo triangulo
escribir "dame un numero para dibujar el triangulo"
leer ancho
escribir "dame otro numero"
leer alto
para fila<-1 hasta ancho
para columna<-1 hasta alto
escribir Sin Saltar"@"
FinPara
escribir ""
        columna<-columna-1
FinPara
FinAlgoritmo


17-Jun-2018 00:13
Nacho Cabanes (+36)

La columna no debe llegar hasta el valor máximo del ancho.

Por el contrario, en la primera fila sólo habrá una columna, 2 en la segunda, 3 en la tercera... luego tu tope para el contador de columnas será el número de la fila actual.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)