[ Foro de BASIC ]

como se operan caracteres y enteros en pseint funciones relacionadas en lenguaje estricto

16-Jul-2018 02:05
Invitado (daniel)
1 Respuestas

necesito apoyo ya que quiero invertir una frase y mostrar si es palindroma o no se como solucionar este error
les mando el pseudocodigo para ver si es posible pedir su ayuda

 
Proceso caracteres_palindromas
	Definir buf como caracter;
	definir cont como entero;
	Definir frase como caracter;
	Definir fraseInvertida como caracter;
	Definir i como entero;
	Escribir "Escriba una frase ";
	Leer Frase;
	cont<-0;
	Para i<-Longitud(Frase) Hasta 0 Con Paso -1 Hacer
		si Subcadena(Frase,i,i)<>" " Entonces
			buf<-buf+ Subcadena(Frase,i,i);
		FinSi
	FinPara
	Para i<-0 hasta Longitud(Frase) Con Paso 1 Hacer
		si Subcadena(Frase,i,i)<>" " Entonces;
			FraseInvertida<-FraseInvertida+Subcadena(buf,cont,cont);
			cont <- cont + 1;
		Sino
			FraseInvertida<-FraseInvertida + Subcadena(Frase,i,i);
		FinSi
	FinPara
	Escribir "la frase invertida es: ";
	Escribir FraseInvertida;
	si FraseInvertida = Frase Entonces
		Escribir "Si son Palindromas";
	Sino
		Escribir "No son Palindromas";
	FinSi
FinProceso
 


esta escrito en perfil estricto


11-Aug-2018 12:42
Nacho Cabanes (+36)

En perfil flexible, tu programa funciona correctamente. En perfil estricto, no podrás usar "+" para concatenar cadenas, sino que deberás usar la función CONCATENAR:

http://www.aprendeaprogramar.com/mod/resource/view.php?id=485
 






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...