[ Foro de Pseudocódigo ]

¿Cómo puedo hacer para que mi juego muestre en qué nivel se está?

10-Aug-2018 05:23
Invitado (.......)
1 Respuestas

El ejercicio es el siguiente:

Hacer un programa que le enseñe a un niño operaciones de suma o
multiplicación. Si el niño adivina las 2 operaciones, aumenta la variable nivel y el ciclo se
repite hasta que el niño pierda. En el momento en que el niño pierda le indica
cual era el número que faltaba y hasta que nivel llegó.

Con el juego no hay problema, peroel nivel no sube. Qué me faltará?

El código que tengo es el siguiente:

 
Proceso punto3taller1
// Hacer un programa que le enseñe a un niño operaciones de suma o multiplicación.
Definir numero1, numero2, resultado, numero3, numero4, numero5, numero6, resultado2, veces, nivel Como Entero;
Repetir
numero1<-azar(9)+1;
numero2<-azar(9)+1;
resultado<-numero1+numero2;
Escribir "Ingresa el número que falta en la suma";
Escribir numero1, " + = ", resultado;
veces<-2;
Mientras veces>0 Hacer
Leer numero3;
Si numero3=numero2 Entonces
Escribir "Muy bien.";
veces<-0;
numero4<-azar(9)+1;
numero5<-azar(9)+1;
resultado2<-numero4*numero5;
Escribir "Ingresa el número que falta en la multiplicación";
Escribir numero4, " x = ", resultado2;
veces<-2;
Mientras veces>0 Hacer
Leer numero6;
Si numero6=numero5 Entonces
Escribir "¡Has subido de nivel!";
veces<-0;
SiNo
Escribir "Respuesta equivocada. Sigue intentando.";
FinSi
veces<-veces-1;
FinMientras
SiNo
Escribir "Respuesta equivocada. Sigue intentando.";
FinSi
veces<-veces-1;
FinMientras
Hasta Que numero3<>numero2 o numero6<>numero5
 
Si numero6=numero5  Entonces
    nivel<-nivel+1
 
Fin Si
Escribir "Has perdido :(. Llegaste hasta el nivel " nivel;
FinProceso
 


Gracias de antemano :(


11-Aug-2018 13:43
Nacho Cabanes (+36)

No acabo de entender. ¿Debe hacer siempre una suma y una multiplicación, y si acierta ambas, sube 1 punto su nivel?

El código está sin tabular y resulta difícil de leer, así que necesitaría saber más cosas para poder ayudarte:

¿Si no acierta la suma o la multiplicación, se le vuelve a preguntar pero no sube de nivel?

¿Si no acierta la suma, se le pregunta otra suma, una multiplicación, o se abandona el programa?

¿Por qué la variable "veces" vale 2? ¿Sólo puede llegar hasta el nivel 2?  ¿Tiene 2 intentos para acertar una suma?

Si le muestras un sumando y el resultado, realmente el niño no tiene que hacer una suma, sino una resta. ¿Es así? Además, el resultado puede ser negativo. ¿Seguro que el niño objetivo ha trabajado con números negativos? (ah, no... veo que el resultado de la suma lo calculas antes de mostrarlo).

De igual modo, si le muestras un multiplicando y el resultado de la multiplicación, el niño debe saber dividir.






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...