[ Foro de Pseudocódigo ]

cues es el pseucodigo y diagrma de flujo de:

26-Nov-2020 00:18
Invitado (ure?a)
2 Respuestas

diagrama de flujo y pseudocodigo Se desea diseñar un sistema de control escolar para que los alumnos, maestros y coordinadores de carrera puedan ingresar. Los alumnos tendrán la posibilidad de revisar calificaciones, adeudos, cargar materias y solicitar sus constancias de estudio; los maestros podrán capturar calificaciones, asignar faltas a los alumnos así como ver avisos; el coordinador tendrá la posibilidad de crear grupos, asignar materias a profesores, registrar alumnos y aplicar correcciones de actas de calificaciones, así mismo podrá verificar el estatus de los alumnos.


05-Dec-2020 07:54
Invitado (Ralph Xiao)

Algoritmo ControlEscolar
Definir usuario,password Como Caracter
Definir menu Como Real
Escribir 'Ingrese nombre de usuario'
Leer usuario
Escribir 'Ingrese contrasena'
Leer password
Si usuario='Alumno' Y password='Aalumno' Entonces
Escribir 'Bienvenido al portal de estudiantes'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'Calificaciones          digite 1'
Escribir 'Adeudos                 digite 2'
Escribir 'Cargar materias         digite 3'
Escribir 'Constancias de estudio  digite 4'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Su calificacion es 9.9'
2:
Escribir 'Su adeudo semestral es de $2,300.00'
3:
Escribir 'Bienvenido al portal de materias'
4:
Escribir 'Selecione la constancia que desea imprimir'
FinSegun
Escribir '------------------------------------------'
Escribir ''
Hasta Que menu>4 O menu<1
SiNo
Si usuario='docente' Y password='Ddocente' Entonces
Escribir 'Bienvenido al portal de maestros'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'capturar calificaciones  digite 1'
Escribir 'asignar faltas           digite 2'
Escribir 'ver avisos               digite 3'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Capture el numero de lista y calificacion del estudiante'
2:
Escribir 'Capture el numero de lista y fecha de falta del estudiante'
3:
Escribir 'Bienvenido al portal de avisos'
FinSegun
Escribir '----------------------------------------------------------'
Escribir ''
Hasta Que menu>3 O menu<1
SiNo
Si usuario='coordinador' Y password='Ccoordinador' Entonces
Escribir 'Bienvenido al portal de coordinadores'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'Crear grupos                                                          digite 1'
Escribir 'asignar materias a profesores                                           digite 2'
Escribir 'registrar alumnos                       digite 3'
Escribir 'correcciones de actas de calificaciones digite 4'
Escribir 'Estatus de alumnos                      digite 5'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Bienvenido al portal de grupos'
2:
Escribir 'Introduzca la materia para asignar'
3:
Escribir 'Capture el numero de lista del estudiante a registrar'
4:
Escribir 'Capture el numero de lista del estudiante y materia a coregir'
5:
Escribir 'Capture el numero de lista del estudiante'
FinSegun
Escribir '-------------------------------------------------------------'
Escribir ''
Hasta Que menu>5 O menu<1
SiNo
Si menu>5 O menu<1 Entonces
menu <- menu
FinSi
Escribir 'Usuario o contrasena son incorrectos'
FinSi
FinSi
FinSi
FinAlgoritmo


05-Dec-2020 08:30
Invitado (Ralph Xiao)

Algoritmo ControlEscolar
Definir usuario,password Como Caracter
Definir menu Como Real
Escribir 'Ingrese nombre de usuario'
Leer usuario
Escribir 'Ingrese contrasena'
Leer password
Si usuario='Alumno' Y password='Aalumno' Entonces
Escribir 'Bienvenido al portal de estudiantes'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'Calificaciones          digite 1'
Escribir 'Adeudos                 digite 2'
Escribir 'Cargar materias         digite 3'
Escribir 'Constancias de estudio  digite 4'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Su calificacion es 9.9'
2:
Escribir 'Su adeudo semestral es de $2,300.00'
3:
Escribir 'Bienvenido al portal de materias'
4:
Escribir 'Selecione la constancia que desea imprimir'
FinSegun
Escribir '------------------------------------------'
Escribir ''
Hasta Que menu>4 O menu<1
SiNo
Si usuario='docente' Y password='Ddocente' Entonces
Escribir 'Bienvenido al portal de maestros'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'capturar calificaciones  digite 1'
Escribir 'asignar faltas           digite 2'
Escribir 'ver avisos               digite 3'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Capture el numero de lista y calificacion del estudiante'
2:
Escribir 'Capture el numero de lista y fecha de falta del estudiante'
3:
Escribir 'Bienvenido al portal de avisos'
FinSegun
Escribir '----------------------------------------------------------'
Escribir ''
Hasta Que menu>3 O menu<1
SiNo
Si usuario='coordinador' Y password='Ccoordinador' Entonces
Escribir 'Bienvenido al portal de coordinadores'
Repetir
Escribir ''
Escribir 'Introduzca la opcion deseada'
Escribir ''
Escribir 'Crear grupos                                                          digite 1'
Escribir 'asignar materias a profesores                                           digite 2'
Escribir 'registrar alumnos                       digite 3'
Escribir 'correcciones de actas de calificaciones digite 4'
Escribir 'Estatus de alumnos                      digite 5'
Leer menu
Escribir ''
Segun menu  Hacer
1:
Escribir 'Bienvenido al portal de grupos'
2:
Escribir 'Introduzca la materia para asignar'
3:
Escribir 'Capture el numero de lista del estudiante a registrar'
4:
Escribir 'Capture el numero de lista del estudiante y materia a coregir'
5:
Escribir 'Capture el numero de lista del estudiante'
FinSegun
Escribir '-------------------------------------------------------------'
Escribir ''
Hasta Que menu>5 O menu<1
SiNo
Si menu>5 O menu<1 Entonces
menu <- menu
FinSi
Escribir 'Usuario o contrasena son incorrectos'
FinSi
FinSi
FinSi
FinAlgoritmo






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...