[ Foro de Pseudocódigo ]

funciones en Pseint

30-Nov-2020 23:04
Invitado (Fernando)
2 Respuestas

Buenas tardes! Nose como utilizar funciones con pseint, quisiera aplicar con for, en maximos. Les dejo un ejercicio por si me pueden ayudar:

// Obligatorio validar ingresos dentro del rango (Si el usuario ingresa un número que no corresponde pedirle lo cambie).
// Obligatorio usar funciones para la opción "mostrar" y "ordenar".
// Armar un menú con switch que contenga las siguientes opciones:
// 1: Crear un vector de 70 posiciones de tipo int.
// 2: Cargar el vector con números al azar entre 900 y 950 con un ciclo for.
// 3: Ordenar el vector de mayor a menor.
// 4: Mostrar el vector completo.
// 5: Pedir un valor y mostrar todos los elementos mayoresal mismo.
// 6: Informar la suma de todos los valores paresdel vector.
// 7: Mostrar el mínimo valor del vector e informar su posición.
// 8: SALIR


30-Nov-2020 23:33
Nacho Cabanes (+73)

¿En PSeInt? ¿Y por qué hablas de "switch" y de "for", que son órdenes de C y los lenguajes derivados?


01-Dec-2020 02:22
Invitado (mycas)

buena tardes/noches

* las funciones de pseint se colocan arriba del programa principal
* si desea capturar un vector usando una funcion , debe formar la funcion
ejemplo

subproceso cap_vec(v por referencia, n)
// si es necesario declare las variables de uso
// v por ferencia acepta vectores de tipo numerico
   define x como entero
   para x=1 hasta n
        escribir "dame el valor ",x,":";leer v[x]
   finpara
finsubproceso

subproceso imp_vec(v por referencia, n)
// si es necesario declare las variables de uso
// v por ferencia acepta vectores de tipo numerico
define x como entero
para x=1 hasta n
     escribir "el valor ",x,": ",v[x]
finpara
finsubproceso

//ahora en en proceso o algoritmo

algoritmo vectores
// tamaño del evector y si es ncesario el tipo
dimension datos[20]
definir datos como real;
escribir "numero de datos: ";leer n
cap_vec(datos,n)
imo_vec(datos,n)
finalgoritmo

ahi esta el inico






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...