[ Foro de Pseudocódigo ]

Imprimir desde una función un vector.

13-Dec-2013 03:53
Jesus Becerril
3 Respuestas

¿Hay alguna manera de imprimir un vector desde una función?
solo mandando llamar a la función?


14-Dec-2013 21:59
Nacho Cabanes (+30)

¿En pseudocódigo o en Python?  ¿Función "prefabricada" o creada por ti?  ¿Imprimir se refiere a mostrar en pantalla?


18-Dec-2013 20:17
Jesus Becerril

pseudocodigo y es función o subproceso creado por mi.... mostrar en pantalla.


20-Dec-2013 22:26
Nacho Cabanes (+30)

El manejo básico de vectores lo tienes aquí:
http://www.aprendeaprogramar.com/mod/resource/view.php?id=420

Y la creación de funciones está aquí:
http://www.aprendeaprogramar.com/mod/resource/view.php?id=486

Por ejemplo, para pedir los datos de un vector y mostrarlo en pantalla harías:

 
Proceso MostrarVector
 
	Dimension datos[6] 
 
	Para i <- 1 Hasta 6 Hacer 
		Escribir "Dime el dato numero ", i
		Leer datos[i] 
	FinPara 
 
	Escribir "Los datos son: " 
	Para i <- 1 Hasta 6 Hacer 
		Escribir datos[i] 
	FinPara 
 
FinProceso 
 


y para crear un subproceso que escriba en pantalla y no devuelva nada, sería

 
Subproceso EscribirVector(datos)
    ...
FinSubproceso
 


Te falta poco más que incluir parte del primer fuente dentro del segundo, y ya lo tienes...  ;-)






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)