[ Foro de Pseudocódigo ]

conversiones con menu

02-May-2019 22:01
Invitado (Pseint)
3 Respuestas

Se tiene como necesidad realizar una calculadora de conversiones de diferentes unidades de medida, la lógica de la programación está establecido de la siguiente manera.
Se debe crear una lista de opciones donde muestre el tipo de conversión o acción a realizar.
===MENU PRINCIPAL===
1. TEMPERATURA
2. LONGITUD
3. MONEDA
4. TIEMPO
5. SALIR
===========================================================
Si el usuario elige la opción de TEMPERATURA se le debe dar la opción para poder elegir de qué tipo de temperatura desea convertir
a. Centígrados
b. Fahrenheit
c. Kelvin
Si eligió la opción “a” debe pedirle que ingrese los grados en centígrados (ejemplo: 30).
Después de ingresas los grados a convertir debe mostrar las opciones hacia qué tipo de temperatura desea convertir.
x. Fahrenheit
y. kelvin
Después de elegir la opción debe realizar el cálculo correspondiente y mostrar el mensaje de la siguiente manera “30 Grados centígrados es equivalente a 60 grados Fahrenheit”
Después debe seguir mostrando el MENU PRINCIPAL
===========================================================
Si el usuario elige la opción LONGITUD se le debe dar la opción para poder elegir de qué tipo de longitud desea convertir
a. Kilómetros
b. Pies
c. Milímetros
Luego se debe realizar el mismo procedimiento que en el caso de TEMPERATURA


02-May-2019 23:16
Nacho Cabanes (+52)

¿Qué has hecho y qué no sabes hacer?


03-May-2019 19:04
Invitado (conversi?n con men?)

avance hasta aqui


Repetir
        // mostrar menu
        Limpiar Pantalla
        Escribir "Menú Principal de converciones"
        Escribir "   1. Tenperatura"
        Escribir "   2. Longitud"
        Escribir "   3. Moneda"
        Escribir "   4. Tiempo"
        Escribir "   5. Salir"
        // ingresar una opcion
        Escribir "Elija una opción (1-5): "
        Leer OP
        // procesar esa opción
        Segun OP Hacer
            1:
                Escribir "Que opción de temperatura dese convertir:"
				Escribir " 1. Centigrados"
                Escribir " 2. Fahrenheit"
                Escribir " 3. Kelvin"
				// ingresar una opcion
				Escribir "Elejir opcion (1-3): "
				Leer OPT
				// procesar esa opción
				Segun OPT Hacer
					1:
						Escribir "Ingrese los grados Centigrados :"
						Leer G
						Definir fahrenheit como entero
						Si fahrenheit <-fahrenheit Entonces
							fahrenheit <- G * 1.8 + 32;
							Escribir G, " grados centígrados equivalen a ", fahrenheit, " grados fahrenheit";
						SiNo
							
						FinSi
						
					2:
						
						kelvin <- centigrado + 273.15;
						Escribir centigrado, " grados centígrados equivalen a ", kelvin, " grados kelvin";
						
						
					2:
						
						
					3:
						
						
						
				FinSegun
				
				
			2:
				
				
				
			3:
				Definir cant, moneda, cambio Como Real;
				//elejir la moneda
				Escribir "seleccione moneda a cambiar";
				Escribir "1:Soles";
				Escribir "2:Dolar";
				Escribir "3:Bitcoin";
				Escribir "4:Euros";
				Leer moneda;
				//esto es para que te muestre el nombre de la moneda que seleccionaste
				Si moneda=1 Entonces
					Escribir "Ud. selecciono Soles";
				Sino
					Si moneda=2 Entonces
						Escribir "Ud. selecciono Dolar";
					Sino
						Si moneda=3 Entonces
							Escribir "Ud. selecciono Bitcoin";
						Sino
							Si moneda=4 Entonces
								Escribir "Ud. selecciono Euros"; 
							FinSi
						FinSi
					FinSi
				FinSi
				Escribir " ";
				//aqui ingresas la cantidad de dinero en soles
				Escribir "ingrese cantidad en soles para cambiar", Sin Saltar;
				Leer cant;
				//aqui segun la variable moneda, se realizara la operacion.
				Segun moneda Hacer
					1:
						Escribir "Cambiar a dolares";
						cambio=cant*0.30;//esto equivale a dolar
					2:
						Escribir "Cambiar a Bitcoin";
						cambio=cant*0.000057;//esto equivale a euros
					3:
						Escribir "Cambiar a Euros";
						cambio=cant*0.27;//esto equivale a bolivares
					De Otro Modo:
						Escribir "la moneda elegida es invalida";
				FinSegun
				Escribir " ";
				Escribir "El cambio en la moneda seleccionada es: ", cambio;
				Escribir " ";
        FinSegun
        Escribir "Presione enter para continuar"
        Esperar Tecla
    Hasta Que OP=5
FinAlgoritmo


 


21-May-2019 10:41
Nacho Cabanes (+52)

Perdona el retraso en contestar.

Varios bloques "segun" anidados pueden hacer un programa difícil de leer. ¿Te permiten crear procedimientos?






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)