[ Foro de Pseudocódigo ]

No puedo hacer que saque el porcentaje

11-May-2019 23:14
Limbert Fuentes Quiroga
2 Respuestas

Buenas tardes
Soy nuevo en programacion y estoy tratando de resolver un ejercicio que hasta el momento no logro hacerlo.
Por favor podrian ayudarme?
Este es el codigo que tengo


Algoritmo sin_titulo
	Definir a,t,t1,tm,sp,pr,c Como Real;
	Mientras a < 10 Hacer
		a=a+1;
		Escribir "Ingrese la temperatura";
		Leer t;
		t1=t;
		si t1 > t Entonces
			tm=t;
		SiNo
			si t > tm Entonces
				tm=t;
				c=c+1;
			SiNo
				si t >= 25 Entonces
					sp=sp+1;
				FinSi
			FinSi
		FinSi
	FinMientras
	Escribir "La temperatura maxima es: ",tm;
	Escribir "Los dias que pasaron los 25 grados son: ",c+sp;
FinAlgoritmo



Gracias


11-May-2019 23:24
Limbert Fuentes Quiroga

Algo que olvide colocar es la pregunta que dice de la siguiente manera:
Se leen 30 numeros enteros que representan la temperatura maxima de cada uno de los dias del mes. Se pide hallar e informar lo siguiente:
1. La temperatura maxima del mes
2. Cuantos dias la temperatura supero los 25 grados
3. El promedio de las temperaturas del mes.

Otro punto tambien es que en mi codigo yo puse que leyera solo 10 numeros para probar con 10 numeros


21-May-2019 11:15
Nacho Cabanes (+42)

No acabo de entender la lógica de tu planteamiento, porque las variables tienen nombres demasiado cortos y no hay comentarios que expliquen lo que pretendes. Aun así, hay algún error lógico, como éste:


t1=t;
si t1 > t Entonces
...


Si t1 toma el valor de t, claramente no va a ser mayor que t.






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)