[ Foro de Pseudocódigo ]

URGENTE PORFA

21-May-2020 00:33
Invitado (Angie)
1 Respuestas

En psaint tengo que hallar la determinante de una matriz 3x3


Algoritmo Matriz_3x3
    
    Definir Fila,Columna Como Entero;
    Definir Matriz Como Entero;
    Dimension Matriz[3,3];
	
	Escribir "" 
	Escribir "Realizar un algoritmo que crea una matriz 3x3, insertando los valores"
	Escribir "" 
	Para Fila<-1 Hasta 3 Con Paso 1 Hacer
        Para Columna<-1 Hasta 3 Con Paso 1 Hacer
			Escribir "un numero";
			Leer Matriz[Fila,Columna];
        Fin Para
    FinPara
	
    Para Fila<-1 Hasta 3 Con Paso 1 Hacer            
        Para Columna<-1 Hasta 3 Con Paso 1 Hacer
            Escribir Sin Saltar Matriz[fila,Columna] " ";
        Fin Para 
		Escribir "";
    FinPara  
FinAlgoritmo


esto solo los organiza como hallo el determinante con psaint


21-May-2020 11:06
Nacho Cabanes (+62)

Puedes hacerlo en una única operación, usando la regla de Sarrus:

https://www.matesfacil.com/matrices/resueltos-matrices-determinantes.html
 






(No se puede continuar esta discusión porque tiene más de dos meses de antigüedad. Si tienes dudas parecidas, abre un nuevo hilo.)