[ Foro de Pseudocódigo ]

Pregunta

01-Jul-2020 19:49
Invitado (Alexandra)
0 Respuestas

Muy buenas, estoy realizando un algoritmo en Pseint en el cual debo organizar una cantidad N de número de mayor a menor, pero cuando ejecuto el código me muestra de menor a mayor, espero que alguien me pueda ayudar, adjuntaré mi código:
Algoritmo mayor_menor
Escribir '¿Cuantos digitos desea ingresar?'
Leer num
Mientras num<>trunc(num) O num<1 Hacer
Escribir 'Error, Ingrese un valor Entero NO negativo'
Leer num
FinMientras
Dimension x[num]
Dimension z[num]
Para i<-1 Hasta num Hacer
Escribir 'Ingrese el ',i,'° valor: '
Leer x[i]
FinPara
max <- x[1]
Para i<-1 Hasta num Hacer
Si x[i]>max Entonces
max <- x[i]
FinSi
FinPara
Para i<-1 Hasta num Hacer
z[i] <- x[i]
FinPara
posmin <- 1
Para i<-1 Hasta num Hacer
min <- max
Para a<-1 Hasta num Hacer
Si z[a]<min Entonces
min <- z[a]
posmin <- a
FinSi
FinPara
x[i] <- min
z[posmin] <- max+1
FinPara
Para i<-1 Hasta num Hacer
Escribir x[i]
FinPara
FinAlgoritmo




Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...