[ Foro de Pseudocódigo ]

Pseudocodigo ejercicio 6.3

18-Oct-2020 19:39
Marcos Parra
1 Respuestas

Crea un programa que genere dos números al azar entre el 0 y el 100, y pida al usuario que calcule e introduzca su suma. Si la respuesta no es correcta, deberá volver a pedirla tantas veces como sea necesario hasta que el usuario acierte.
Pista: como verás en el apartado 10, para generar un número al azar del 0 al 100 puedes hacer numero <- AZAR(101)

Soy nuevo en esto de la programaciñón quisiera que me dijeran si mi algoritmo sobre este ejercicio es correcto y si puede tener errores que no logro ver.

Algoritmo Mientras

Escribir "Resuelve la siguiente suma "
primerNumero <- azar(101)
Escribir  primerNumero
segundoNumero <- azar (101)
Escribir segundoNumero
suma <- primerNumero + segundoNumero
Escribir "Respuesta "
Leer x

Mientras x <> suma Hacer
Escribir "Incorrecta"
Escribir "Vuelve a intentar"
Leer x
FinMientras
Si x = suma Entonces
Escribir "Correcto"

Fin Si


FinAlgoritmo


18-Oct-2020 20:22
Nacho Cabanes (+72)

Es casi perfecto.

Sólo te sobra una orden: el último "Si" es innecesario, porque cuando salgas del "Mientras" ya será con total seguridad porque la respuesta es correcta, no necesitas comprobarlo.






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...