[ Foro de Pseudocódigo ]

Escribir un algoritmo

22-Apr-2021 08:28
Invitado (Javiera Sep?lveda)
1 Respuestas

Escribir un algoritmo con su respectivo DF que transforme grados Celsius en Fahrenheit y viceversa.
El algoritmo debe tener la opción de cual conversión se quiere realizar(Celsius ? Fahrenheit o Fahrenheit? Celsius). Recordar C = 5/9(F ? 32).


28-Apr-2021 02:18
Invitado (Ronie )

Algoritmo transformacion
definir opcion como entero;
definir celsius, farenheit como real;

escribir"1.Transformar de Celsius a Farenheint";
escribir"2.Transformar de Farenheit a Celsius";
escribir"Selecciona una opción";
leer opcion;
Segun opcion Hacer
1:
escribir"Ingresa los grados celsius :";
leer celsius;
farenheit<-(celsius*9/5)+32;
escribir"Los grados en Farenheit son :",farenheit;

2:
escribir"Inqresa los grados farenheit :";
leer farenheit;
celsius<-(farenheit-32)*5/9;
escribir"Los grados en Celsius son : ",celsius;
De otro modo:
escribir"Opcion invalida";


FinSegun

FinAlgoritmo






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...