[ Foro de Pseudocódigo ]

alguien puede ayudarme

26-Apr-2021 00:29
Invitado (black)
1 Respuestas

Ingresar cinco números y obtener el producto de los mismos.
• Usando sumas implementar la multiplicación de dos números.
• Ingresar cinco edades y obtener el promedio de edades.
• Al ingresar el número cinco imprimir cinco, al ingresar el numero 10 imprimir diez, al ingresar el numero 15 imprimir quince, ingresar el numero 20 imprimir veinte, en caso contrario imprimir un mensaje


28-Apr-2021 02:45
Invitado (RonieXD)

Antes de que veas la respuesta te recomiendo intentar hacer algunos por tu cuenta, suerte!! :))



ALGORITMO 1:

Ingresa cinco números y obten su producto:

Proceso algoritmo1
definir num1,num2,num3,num4,num5 como real;
definir producto como real;
escribir"Ingresa el número 1:";
leer num1;
escribir"Ingresa el número 2:";
leer num2;
escribir"Ingresa el número 3:";
leer num3;
escribir"Ingresa el número 4 :";
leer num4;
escribir"Ingresa el número 5 :";
leer num5;
producto<-num1*num2*num3*num4*num5;
escribir"El producto de los numeros ingresados es :",producto;

FinProceso


ALGORITMO 2:

Usando sumas implementar la multiplicación de dos números:

Proceso algoritmo2
definir num1,num2,suma como entero;
definir x como entero;
suma<-0;
escribir"Ingresa el número 1:";
leer num1;
escribir"Ingresa el número 2:";
leer num2;
Para x<-1 Hasta num2 Con Paso 1 Hacer
suma<-num1+suma;
FinPara
escribir "El resultado de la multiplicación es :",suma;


FinProceso


ALGORITMO 3

Ingresar 5 edades y obtener el promedio de las edades :


Proceso algoritmo3

definir edad como entero;
definir x,suma como entero;
definir promedio como real;

suma<-0;
Para x<-1 Hasta 5 Con Paso 1 Hacer
escribir"Ingresa la edad ",x;
leer edad;
suma<-suma+edad;
FinPara

promedio<-suma/5;

escribir"El promedio de las edades es : ",promedio;

FinProceso


ALGORITMO 4

Al ingresar el numero 5 imprimir cinco, al ingresar el numero 10, imprimir 10, al ingresar el numero 15, imprimir 15, al ingresar el numero 20, imprimir 20. En caso contrario imprimir un mensaje:

Proceso algoritmo4
definir num como entero;
escribir"Ingresa un numero :";
leer num;
Segun num Hacer
5:
escribir"Cinco";
10:
escribir"Diez";
15:
escribir"Quince";
20:
escribir"Veinte";
De Otro Modo:
escribir"Los valores ingresados no son : 5,10,15,20";
FinSegun









Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...