[ Foro de Pseudocódigo ]

pseudocodigo lr

14-Jun-2021 18:11
Invitado (laura)
1 Respuestas

1. En una empresa que tiene 10 empleados se quieren conocer el pago que deberá efectuar la misma por algunos conceptos. Se sabe que:
Se trabaja en dos turnos, diurno y nocturno, en el turno diurno cada hora trabajada se paga 250 pesos y el turno nocturno a 370 pesos, si es día domingo el pago por la hora es de 500 pesos y el nocturno es de 750.
• Calcular:
o Total de Sueldos a Abonar.
o Cantidad de empleados que superan los $10.000 pesos de sueldo.
o El Sueldo mayor y el sueldo menor que se abona en dicha empresa.


17-Jun-2021 06:31
Invitado (LENNY GARCIA)

lgoritmo sin_titulo
smayor<-0
Para i<-1 Hasta 10  Hacer
acu_sueldo<-0
r<-'s'
Mientras r='s' Hacer
Escribir 'Ingrese horas trabajadas'
Leer ht
Escribir 'Ingrese turno laborado'
Leer turno
Escribir 'Ingrese día laborado'
Leer dia_laborado
Si turno='dia' Entonces
Si dia_laborado='dom' Entonces
acu_sueldo<-acu_sueldo+ht*500
SiNo
acu_sueldo<-acu_sueldo+ht*250
Fin Si
SiNo
Si dia_laborado='dom' Entonces
acu_sueldo<-acu_sueldo+ht*750
SiNo
acu_sueldo<-acu_sueldo+ht*350
Fin Si
Fin Si
Escribir '¿Otro día laborado(Si o no)?'
Leer r
Fin Mientras
Si acu_sueldo>10000 Entonces
c<-c+1
Fin Si
sueldo<-acu_sueldo
Si sueldo>smayor Entonces
smayor<-sueldo
SiNo
smenor<-sueldo
Fin Si
tot_sueldos<-tot_sueldos+acu_sueldo
Fin Para
Escribir 'Total de sueldo a abonar:',tot_sueldos
Escribir 'Cantidad de empleados que superan los $10.000 pesos de sueldo:',c
Escribir 'Sueldo mayor:',smayor
Escribir 'Sueldo menor:',smenor
FinAlgoritmo
Por favor opinen algo. El sistema no me tomó el registro






Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...