[ Foro de Pseudocódigo ]

Definir una Variable

11-Oct-2022 14:53
Mximo Ferrero
0 Respuestas

Hola, a todos estoy haciendo un pequeño programa de un video en youtube sobre un almacen pero parece ser que el que hace el video todo le funciona bien lo haga como lo haga y eso no les pasa a los demás es un programa con PSeint, que es muy sencillo
pero a mi me da un error y no se como Definir la Variable bolita, la he Definido con todos los tipos de variables que se pueden definir en PSeint , Entero, Real, Caracter, Logico , y todas me da error y como el del video no la declara de ninguna manera no se como tengo que definirla :

Algoritmo Segun_Almacen


Definir compra como Entero;
Definir bolita como  Entero;
Definir desc como  Real;
Definir color como Caracter;



Escribir " Ingrese el valor de su compra";
Leer compra;

Escribir "Seleccione según el color de la bolita para su descuento";
Escribir " 1. Roja";
Escribir " 2. Azul";
Escribir " 3. Verde";
Escribir " 4. Blanca";
Leer bolita;

Segun bolita Hacer
1:
desc<- compra;
color<- "Roja";
2:
des <- compra * 0.50;
color<- "Azul";
3:
desc<- compra * 0.25;
                       color<- "Verde";
4:
des<- 0;
color<- "Blanca";
De Otro Modo:
Escribir "Ese color no existe!";
Fin Segun

FinAlgoritmo
cuando llega a leer la bolita da un error  si pongo Entero dice que no coincide el valor , si pongo otro valor dice que el valor
de la variable de Segun tiene que ser un Entero.
A ver si alguien sabe la solución
Gracias




Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...