[ Foro de Pseudocódigo ]

ayuda pseint

12-Feb-2024 00:07
Invitado (Sebastian)
0 Respuestas

Hola a todos, tengo un problema con mi codigo. al querer solicitar mediante el menu, la opcion 2. no me muestra los datos ya ingresados. ayuda porfa.
aqui mi codigo:

// Función para ingresar datos de un bus
Funcion IngresarDatosBus(matricula,nombre,problema,fecha,sector)
   Escribir "Ingresando datos del bus..."
   Escribir "Matrícula del bus: "
   Leer matricula
   Escribir "Nombre del chofer: "
   Leer nombre
   Escribir "Problema a reparar: "
   Leer problema
   Escribir "Fecha de ingreso (DD/MM/AAAA): "
   Leer fecha
   Escribir "Sector asignado: "
   Leer sector
   
//    Matriculas[Longitud(Matriculas) + 1] <- matricula
//    Nombres[Longitud(Nombres) + 1] <- nombre
//    Problemas[Longitud(Problemas) + 1] <- problema
//    Fechas[Longitud(Fechas) + 1] <- fecha
//    Sectores[Longitud(Sectores) + 1] <- sector
FinFuncion


// Función para imprimir datos de los buses
Funcion ImprimirDatosBuses(matricula,nombre,problema,fecha,sector)
   Escribir "=== Listado de Buses ==="
   Para i = 1 Hasta Longitud(Matriculas) Con Paso 1 Hacer
       Escribir "Bus ", i, ":"
       Escribir "Matrícula: ", matricula[i]
       Escribir "Chofer: ", nombre[i]
       Escribir "Problema: ", problema[i]
       Escribir "Fecha de ingreso: ", fecha[i]
       Escribir "Sector asignado: ", sector[i]
       Escribir ""
   FinPara
FinFuncion


// Programa principal
Algoritmo controlbuses
// Definición de variables
Definir matricula Como Caracter
Definir nombre Como Caracter
Definir problema Como Caracter
Definir fecha Como Caracter
Definir sector Como Entero
Definir MaxBuses Como Entero
Definir EspacioDisponible Como Entero
Definir OpcionMenu Como Caracter
MaxBuses = 10 // Máximo 10 buses
EspacioDisponible = 5 // Espacio disponible inicial
Dimension Matriculas[MaxBuses]
Dimension Nombres[MaxBuses]
Dimension Problemas[MaxBuses]
Dimension Fechas[MaxBuses]
Dimension Sectores[MaxBuses]

// Menú de opciones
Repetir
Escribir "==== Menú ===="
Escribir "1. Ingresar datos de un bus"
Escribir "2. Mostrar datos de los buses"
Escribir "3. Salir"
Escribir "Ingrese su opción: "
Leer OpcionMenu

Segun OpcionMenu Hacer
"1":
Si Longitud(matricula) < MaxBuses Entonces
IngresarDatosBus(matricula,nombre,problema,fecha,sector)
EspacioDisponible = EspacioDisponible - 1
Sino
Escribir "No hay espacio disponible para más buses."
FinSi
"2":
Si Longitud(matricula) >= 1 Entonces
ImprimirDatosBuses(matricula,nombre,problema,fecha,sector)
Sino
Escribir "No hay buses registrados."
FinSi
"3":
Escribir "Saliendo del programa..."
De Otro Modo:
Escribir "Opción inválida. Por favor, seleccione una opción válida."
FinSegun
Hasta Que OpcionMenu = "3"
FinAlgoritmo







Si ya eres usuario del sistema, puedes contestar desde tu cuenta y así ganar prestigio.

Si sólo eres un visitante, puedes optar por...